logo Homepage
+  NewbieContest
|-+  Programmation» Autres langages» BATCH Commande xcopy
Username:
Password:
Pages: [1]
  Imprimer  
Auteur Fil de discussion: BATCH Commande xcopy  (Lu 4415 fois)
Skyroryk
Profil challenge

Classement : 15699/54391

Néophyte
*
Hors ligne Hors ligne
Messages: 19


Voir le profil
« le: 22 Novembre 2018 à 14:25:31 »

Bonjour, je ne sais pas si le batch est un language compilé ou pas, donc j'ai mis mon message ici.

Je voudrais faire une tâche dans le planificateur de tâche qui copie les fichiers de ": P/" (un emplacement réseau) à ":Q/" (un autre emplacement réseau) à chaque ouverture de session.

Donc je fais :

xcopy ": P/" ":Q/" /e /h /y /c /i
pause


Quand je l'ouvre manuellement dans ": P/" ou ":Q/" tout va bien. Mais dès que je le met dans le Planificateur de tâche (Donc dans ":C/Windows/System32/GroupPolicy/Users/Logon") quand j'ouvre ma sessions, il ouvre le cmd :

user: xcopy ....
Erreur : P introuvable
0 fichiers copiés
pause


Infos supplémentaires : (je ne sais pas si vous en avez besoin) L'utilisateur qui se connecte n'est pas admin il est seulement Utilisateurs. Le fichier GroupPolicy est caché pour les Utilisateurs. Mais, le cmd s'ouvre. Donc je pense qu'ils ont accès au script. Ils ne peuvent pas modifier, supprimer un fichier du System32 (n'importe lequel). Sur mon ordinateur j'ai une seule session admin et j'ouvre ce fichier avec les autres sessions (non admin).

Du coup, que faut-il faire ??

Merci d'avance




ATTENTION !!

J'ai mis les : P décollés car sinon il me met un smiley. En fait, ils sont collés. Merci


« Dernière édition: 22 Novembre 2018 à 14:27:20 par Skyroryk » Journalisée
neibb

Profil challenge

Classement : 258/54391

Membre Junior
**
Hors ligne Hors ligne
Messages: 76


Voir le profil
« #1 le: 22 Novembre 2018 à 16:14:17 »

Salut,

Citation
user: xcopy ....
Erreur : P introuvable
Il s'agit peut être d'une histoire de chemin relatif/absolu...
Sinon naïvement, c'est pas des '\' normalement sous windows? (C:\)

Citation
L'utilisateur qui se connecte n'est pas admin il est seulement Utilisateurs. Le fichier GroupPolicy est caché pour les Utilisateurs. Mais, le cmd s'ouvre. Donc je pense qu'ils ont accès au script. Ils ne peuvent pas modifier, supprimer un fichier du System32 (n'importe lequel). Sur mon ordinateur j'ai une seule session admin et j'ouvre ce fichier avec les autres sessions (non admin).
Ça c'est une histoire de permissions, tu dois pouvoir vérifier (et éditer) directement avec : Clic droit/ Propriétés/ Partage (ou quelque chose dans le genre).
Sinon le plus simple, si cmd s'ouvre, c'est de regarder directement ce à quoi tu as accés par là.

A oui aussi,
Citation
je ne sais pas si le batch est un language compilé ou pas
C'est pour faire du script, c'est un langage interprété, et donc non compilé.

++
Journalisée

neibb.
S0410N3
Administrateur

Profil challenge

Classement : 10/54391

Membre Héroïque
*****
Hors ligne Hors ligne
Messages: 1260


Voir le profil WWW
« #2 le: 23 Novembre 2018 à 08:59:34 »

Il faut monter les lecteurs réseau avant le xcopy à base de : net use p: \\host\share
Dans le contexte du planificateur de tâches même si tu les as déjà mappés pour le compte il ne les voit pas.

Ceci dit tu devrais plutôt t'orienter vers robocopy qui est bien plus puissant (rien que pour le /mir) et gère les chemins UNC.
Journalisée

Enjoy (copyleft de quelqu'un qui a trop parlé)

S0410N3

-------------------------------------------------------------------------------------
La folie est le prix à payer pour le temps passé à être trop lucide.
-------------------------------------------------------------------------------------
http://forum.hardware.fr/hfr/Discussions/Societe/francais-repere-repaire-sujet_19265_1.htm
Skyroryk
Profil challenge

Classement : 15699/54391

Néophyte
*
Hors ligne Hors ligne
Messages: 19


Voir le profil
« #3 le: 26 Novembre 2018 à 10:01:53 »

En fait mon programme est :

xcopy "\" ":Q\" /e /h /i /c :Y
pause

Donc, on est dans un réseau, avec des comptes Utilisateurs. Sur un PC, si un utilisateur ne s'est jamais connecté, et qu'il se connecte pour la première fois (Préparation du bureau ...), le programme fonctionne. Mais pour quelqu'un qui s'est déjà connecté, il ne fonctionne pas.

Comment faire ?

Merci
Journalisée
Pages: [1]
  Imprimer  
 
Aller à: